胖头鱼的鱼缸

数据库管理-第387期 吐槽一下OCP部署(20251110)

数据库管理-第387期 吐槽一下OCP部署(20251110)

作者:胖头鱼的鱼缸(尹海文)
Oracle ACE Pro: Database
PostgreSQL ACE

10年数据库行业经验
拥有OCM 11g/12c/19c、MySQL 8.0 OCP、Exadata、CDP等认证
墨天轮MVP,ITPUB认证专家
圈内拥有“总监”称号,非著名社恐(社交恐怖分子)

公众号:胖头鱼的鱼缸
CSDN:胖头鱼的鱼缸(尹海文)
墨天轮:胖头鱼的鱼缸
ITPUB:yhw1809
IFClub:胖头鱼的鱼缸
除授权转载并标明出处外,均为“非法”抄袭

914fcc7ad57defa7868c3be1ca7fb4f5.jpg
上周不是通过OCP部署了一套4.4.1社区版集群么,装完后就发现运行OCP的主机,MetaDB的可用内存已经100%分配了,运行也卡得很,因此想着将OCP主机配置调整为6C24G 100G磁盘重新部署一下,然后出现了下面的问题。

1 问题复现

之前部署OCP的时候,在MetaDB配置租户ocp_monitor的时候,是将内存调整到了4G的(默认8G),如果按照默认方式配置则会在预检查时出现报错:
df4cace07d3a9a71418a0495532368a9.png
d598427d8010b4a6de6e7d851fcdd628.png
因此想着在MetaDB中将memory_limit调大。
663859c3fe85b90d58f3d57a419cc573.png
但是在实际部署中,在创建resource pool的时候仍然会报错。
0aff09e3a88a46ea33cba7147652c85b.png
检查日志和配置相关信息,即便是配置了新的memory_limit,实际部署过程中仍然会使用“自动分配”的大小,即小于租户ocp_meta默认4G+ocp_monitor默认8G,共12G÷0.8=15G的需求,不知这是一个我配置流程的问题,还是“自动分配”相关的BUG。

最后还是只能将ocp_monitor租户的内存配置调整成4G,完成安装。

2 调整内存

安装完成后MetaDB的内存分配依然是100%,我的目标仍然是将ocp_monitor的内存配置调整到默认的8G。

2.1 调整集群

首先需要将MetaBD本身的memory_limit调大:
image.png
image.png
image.png
image.png
image.png
image.png

2.2 调整租户

然后调整ocp_monitor租户的内存配置:
image.png
image.png
image.png
image.png
image.png
image.png
image.png
image.png
调整完成后MetaDB的内存分配如下:
image.png

3 其他小问题

在上一篇文章,某个发布平台的评论中还发现了一个小的默认书写错误:
3f70b6d5d6dc958d4856114c918736d1.png
default少了个f。

总结

本文浅浅吐槽了一下OCP部署中MetaDB内存配置的问题。
老规矩,知道写了些啥。